..

CentOS 64 Bit Linux 6.2 - LiS 2.19.2 Compilation Problem

..

Developer Group

Developer Group
Connect with thousands of other developers to brainstorm ideas, share best practices and tips - or just chat about the latest emerging technologies making noise in the field. And of course, get the most up-to-date service and support news from Dialogic.
Dialogic Global Call and R4 APIs

CentOS 64 Bit Linux 6.2 - LiS 2.19.2 Compilation Problem

  • I am unable to install LiS with the Service Release 6.1 for CentOS Linux 6.2 64 bit
    I am using D4PCIUFEQ board.

    My gcc version is 4.4.6 20110731 (Red Hat 4.4.6-3)
    My Kernal version is 2.6.32-220.4.2.el6.x86_64
    Kernel source : /usr/src/kernels/2.6.32-220.4.2.el6.x86_64
    I am getting error in ldl.c. Following is the screenshot of the error

     

    But if I try the same in Centos 5.1 64 Bit is working fine with
    gcc version 4.1.2 20080704 (Red Hat 4.1.2-51)
    Kernal version : 2.6.18-164.el5-x86_64

     Please help.

  • According to the release update, neither RHEL/CentOS 6.2 nor 64-bit are supported:

    "With Service Update 320, the following 32-bit versions of Linux operating system distributions (OSDs) are now supported...Red Hat Enterprise Linux 6...Note: When installing the Linux STREAMS (LiS) package, LiS 2.19.2 must be installed for Red Hat Enterprise Linux 6..."

    I suspect that you might succeed with 6.2 32-bit non-PAE non-XEN. Also check that you are using LiS 2.19.2, not 2.19.1.

  • Sorry, just noticed in your title that you said 2.19.2

  • Thank you for your reply. Mine is non-XEN . I think in case of centos 6+  we have just one devel package so i am sure mine is non-PAE source .My concern is We recently bought the driver from Dialogic for a price unaware it will not work in 64 bit linux systems. I am not sure if Dialogic will be able to help us in this case. Do you know if dialogic is planning to release one for 64 bit linux in near future?

    One more question 

    In my case almost all packages in the DVD got installed except Linux Streams..Can we use Linux Fast Streams from openss7 instead of LiS.

     

     

  • sam@glenwoodmicro.net

    ...Do you know if dialogic is planning to release one for 64 bit linux in near future?...

    I do not - you would have to ask them. While it would be nice, my feeling is that they have no interest in *ever* supporting 64-bit Linux in this software release so we just dumb-down our telephony servers to comply with Dialogic's world-view.

    sam@glenwoodmicro.net

    In my case almost all packages in the DVD got installed except Linux Streams..Can we use Linux Fast Streams from openss7 instead of LiS.

    Sorry, I have no idea except that it wouldn't be "supported".

     

  • Correct on no support for 64-bit with Linux at this time.  CentOS will be supported if it is a version number that exactly matches the supported Red Hat builds (including kernel, LiS etc.)

  • [ SOLVED ] Thanks Guys As you all said The solution is " It simply  does not work in 64 bit Linux." Working perfectly without any problem in centos 6.2 32 bit. Hope Dialogic considers redhat 64 bit in future.

     

     

  • Hi,

    We've got a version of 2.19.1 running in a 64-bit CentOS environment.  Where did you get the 2.19.2 ?  I'd like to have a look at it......

     

    Thanks,

     

    Derek

     

  • Lis 2.19.2 came with the Driver cd we bought from Dialogic.