..

Predefined XML entities

..

Developer Group

Developer Group
Connect with thousands of other developers to brainstorm ideas, share best practices and tips - or just chat about the latest emerging technologies making noise in the field. And of course, get the most up-to-date service and support news from Dialogic.
PowerMedia XMS Media Server

Predefined XML entities

  • Hi,

    I had some problems getting flac to work with the supplied Onkyo (NR717) renderer profile, but I've been able to make my own which is currently playing both mp3 and flac correctly at least. I'll work further on it and post it if I find some relevant place to do that when I consider it "finished". But, I have one problem that I can't seem to figure out. UMS encodes the text it sends to my Onkyo with HTML character entity (eg & apos ; for ' ), which the Onkyo doesn't understand and just writes out like any other text. The results are hard to read. I don't know what the DLNA standard says about text encoding, but serviio did this correct for my Onkyo. Is there anywhere, in the renderer config or elsewhere, where I can specify this encoding?

    Please help.

    I didn't find the right solution from the Internet.

    References:-
    http://www.universalmediaserver.com/forum/viewtopic.php?t=3496
    Online Video Production Studio

    Thanks!

  • Thank you for your post.  It looks like this is not related to our media server integration, but rather some issues with the basic XML entities interfacing with another product.  It would seem in the link that you referenced that they are making some changes, but it is possible that they may still have issues.  It is best to follow up with the Onkyo support team to work with them to handle the UMS encodes.