..

XMS 4 - Is it possible to control the SDP

..

Developer Group

Developer Group
Connect with thousands of other developers to brainstorm ideas, share best practices and tips - or just chat about the latest emerging technologies making noise in the field. And of course, get the most up-to-date service and support news from Dialogic.
PowerMedia XMS Media Server

XMS 4 - Is it possible to control the SDP

  • Hi,

    We are evaluting the XMS.

    How can I control so that the SDP, with the outgoing INVITE, contains only offer of traditional PSTN codecs like G711 A/u-law (and perhaps RFC2833 for DTMF) and nothing else?

    Here is an example of what I would like to be removed (REM) from the SDP:

    ***************
    Session Description Protocol
    Session Description Protocol Version (v): 0
    Owner/Creator, Session Id (o): xmserver 1574156367 1574156368 IN IP4 10.47.12.31
    Session Name (s): xmserver
    Connection Information (c): IN IP4 10.47.12.31
    REM -> Bandwidth Information (b): AS:80
    Time Description, active time (t): 0 0
    REM -> Session Attribute (a): group:BUNDLE audio
    REM -> Session Attribute (a): msid-semantic:WMS 9597bbe775cb4d37bec47366488817af
    Media Description, name and address (m): audio 49152 RTP/AVP 0 8 102
    REM -> Bandwidth Information (b): AS:80
    Media Attribute (a): rtpmap:0 pcmu/8000
    Media Attribute (a): rtpmap:8 pcma/8000
    Media Attribute (a): rtpmap:102 telephone-event/8000
    Media Attribute (a): fmtp:102 0-15
    Media Attribute (a): sendrecv
    REM -> Media Attribute (a): rtcp-mux
    REM -> Media Attribute (a): msid:9597bbe775cb4d37bec47366488817af 2d4bb941bc894c0f97b5cb7b71211216
    REM -> Media Attribute (a): ssrc:4144459060 cname:9fWTCtzeGXOq
    REM -> Media Attribute (a): mid:audio
    ***************

  • It is not possible to edit / remove lines in the SDP and there is no provision in the Web UI to do this. Having said that, if you simply want to offer G.711 + RFC2833 then you should navigate to the Codecs > Profiles page in the UI and make sure that only the "pcmu" and "pcma" options under "Audio Codecs" are enabled.

  • "make sure that only the "pcmu" and "pcma" options under "Audio Codecs" are enabled."

    MD:

    Thanks for the reply. And that's for confirming what I suspected.

    :)